实验 13 EIGRP 路由协议的配置

2023-05-16

一.实验目的
掌握路由器 EIGRP 路由协议的配置方法。
二.实验要点
通过对路由器 A 和路由器 B启用 EIGRP 路由协议,使路由器 A 可 Ping 通路由器 B 所连的各个网络,
反之,亦然。
三.实验设备
路由器 Cisco 2621 两台,交换机 Cisco 2950 两台,带有网卡的工作站 PC 至少两台。
四.实验环境
这里写图片描述

五.实验步骤
1. 如图对路由器 A 及路由器 B 的各个接口配置好 IP 地址
l 在路由器 A (假设为 DCE 端)上
router>en
router#conf t
router(config)#hostname RouterA
RouterA(config)#int s0/0
RouterA(config-if)#ip add 10.0.0.1 255.255.255.0
RouterA(config-if)#cl ra 64000
RouterA(config-if)#no sh
RouterA(config)#int f0/0
RouterA(config-if)#ip add 192.168.0.1 255.255.255.0
RouterA(config-if)#no sh
RouterA(config-if)#exit
l 在路由器 B (假设为 DTE 端)上
router>en
router#conf t
router(config)#hostname RouterB
RouterB(config)#int s0/0
RouterB(config-if)#ip add 10.0.0.2 255.255.255.0
RouterB(config-if)#no sh
RouterB(config)#int f0/0
RouterB(config-if)#ip add 192.168.1.1 255.255.255.0
RouterB(config-if)#no sh
RouterB(config-if)#exit
实验结果:
a. 在路由器 A 上是否能 ping 通路由器 B 的串口 S0/0 (10.0.0.2)
b. 在路由器 A 上是否能 ping 通路由器 B 的以太口 F0/0 (192.168.1.1)
2. 在路由器 A 和路由器 B 上分别配置 EIGRP 路由协议
在路由器 A 上: RouterA (config)#router eigrp 100
RouterA(config-router)# net 10.0.0.0
RouterA(config-router)# net 192.168.0.0
在路由器 B 上: RouterB (config)# router eigrp 100
RouterB(config-router)# net 10.0.0.0
RouterB(config-router)# net 192.168.1.0
实验结果:
a. 在路由器 A 上是否能 ping 通路由器 B 的串口 S0/0 (10.0.0.2)
b. 在路由器 A 上是否能 ping 通路由器 B 的以太口 F0/0 (192.168.1.1)
3. 在路由器 A 与路由器 B 上监测和诊断 EIGRP 路由协议。
show ip eigrp interfaces 查看 EIGRP 协议的接口信息
show ip eigrp neighbors 查看 EIGRP 协议的邻居信息
show ip eigrp topology 查看 EIGRP 协议的拓扑信息
show ip eigrp traffic 查看 EIGRP 协议的流量信息
debug ip eigrp 监测 EIGRP 路由事件信息
debug eigrp packet 监测 EIGRP 使用的各种信息包的收发情况

Router 0上的配置:
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#no ip address
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router(config-if)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms

Router#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
//当未配置eigrp时,无法ping通
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp 100
Router(config-router)#net 10.0.0.0 
Router(config-router)#net 192.168.0.0
Router(config-router)#exit
Router(config)#
%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.0.0.2 (Serial0/0) is up: new adjacency
Router(config)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/7 ms

Router 1上的配置:
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to upip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#route eigrp 100
Router(config-router)#net 10.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.0.0.1 (Serial0/0) is up: new adjacency
Router(config-router)#net 192.168.1.0
Router(config-router)#exit

主机A和主机B需要自己配置IP地址和子网掩码,网关。

六.实验总结
1.比较 RIP、OSPF、EIGRP 三种路由协议的配置命令
2.从 RIP、OSPF、EIGRP 三种路由协议的诊断信息中分析各自的特性。

本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系:hwhale#tublm.com(使用前将#替换为@)

实验 13 EIGRP 路由协议的配置 的相关文章

  • 正则表达式匹配URL或者网址

    正则表达 一 正则表达式 xff1a http ftp https w 43 w 43 43 w 64 61 amp amp 43 w 64 61 amp amp 43 匹配 xff1a http regxlib com Default a
  • Python3 logging详解

    Python3中logging详解 官方文档中 xff0c logging的5个层级 xff1a 实例代码 xff1a def logs time prov type log name 61 prov 43 39 39 43 time fi
  • python3爬虫 链接+表格+图片 思路

    左侧部门列表每点击一次都有一个新的js网页出现 xff0c Request URL可以明确看出网址 xff0c 且每个网址都有其规律 xff1a 点击了三个部门 xff0c 返回的网址如下 xff0c 可以看出是有规律的 xff0c 此处d
  • 跟我一起学MongoDB之——可视化工具Compass的简单使用

    首先官方为大家介绍了一下MongoDB Compass的主要功能 xff1a 1 对数据的可视化 2 插入 修改 删除 3 调试 优化 进入Compass首先出现连接界面如下 xff08 此处我使用的是我操作时候的界面状态 xff09 直接
  • sqluldr2 报错ora-24345: A Truncation or null fetch error occurred

    source etc profile source root bash profile unset NLS LANG sqluldr2 user 61 sjgj sjgj 64 10 254 4 196 1521 client query
  • 车牌号校验正则表达式

    一 车牌号校验规则 1 常规车牌号 xff1a 仅允许以汉字开头 xff0c 后面可录入六个字符 xff0c 由大写英文字母和阿拉伯数字组成 如 xff1a 粤B12345 2 武警车牌 xff1a 允许前两位为大写英文字母 xff0c 后
  • 日语学习资料汇总(可下载)

    直播课程推荐 xff1a 妞妞 大家的日语 侧重考级 天易外语 旧版 标准日本语 娜娜 日语讲堂 津波老师 新版标准日本语 爱知 实用日语口语 在直播课程有预告http www fairage com total jsp type 61 1
  • 成熟男人与24岁女孩精彩对白(转)

    烛光晚餐 桌两边 xff0c 坐了男人和女人 我喜欢你 女人一边摆弄着手里的酒杯 xff0c 一边淡淡的说着 我有老婆 男人摸着自己的手上的戒指 我不在乎 xff0c 我只想知道 xff0c 你的感觉 你 xff0c 喜欢我嘛 xff1f
  • jsessionid的困扰

    问题 xff1a 向某银行发送支付请求时 xff0c 如果客户端cookie开启 xff0c 第一次请求时 xff0c 请求地址会自动增加一jsessionid 第二次没有问题 如果客户端cookie关闭 xff0c 无论如何请求地址会自动
  • 2级基本编程问题(—)(C++)

    问题 xff08 1 xff09 时间转换 问题描述 xff1a 给定一个从0秒开始计时的秒数 xff0c 请将其转换为X X X的格式 输入 xff1a 输入一个秒数n xff0c 且这个秒数0 n 86400 输出 xff1a 输出这个
  • 报错<BEA-101017> error:java.net.SocketException解决

    最近项目登录不了 xff0c 报错为 xff1a lt BEA 101017 gt error java net SocketException Connection reset by peer socket write error 最后问
  • 专业IT管理人才必备十大能力

    IT168 技术文章 作为IT技术人员 xff0c 相信没有一个人愿意永远在底层编写程序或做简单的系统维护 经过一段时间的技术和经验的积累 xff0c 很多人都向往更高层的职位 xff0c 但如何能成为一个专业的IT管理人才 xff0c 并
  • Modbus超时时间设置

    很多同学在做Modbus通讯时 xff0c 需要连续读取多个现场设备的数据 xff0c 虽然也编写了Modbus轮询的程序 xff0c 但是有时还是无法正常通讯 有时虽然能够保证通讯 xff0c 但是所有现场设备的轮询周期很长 本文将从MB
  • Modbus测试工具(Modbus Master调试工具)

    Modbus Poll是Modbus主设备模拟工具 xff0c 帮助Modbus通讯设备开发人员进行Modbus通讯协议的模拟和测试 xff0c 用于监控 测试 调试Modbus通讯设备 可以多个窗口中同时监控多个Modbus子设备 xff
  • 如何移除Googleads.g.doubleclick.net 病毒

    Related Symptoms about Googleads g doubleclick net Googleads g doubleclick net is very tricky and stubborn redirect viru
  • confluence 下admin用户密码恢复方法

    搭建了一个confluence平台 xff0c 日子久了 xff0c 管理员admin密码居然忘记了 以下恢复方法 xff1a 1 运行此sql 找到你的管理员帐户 xff1a select u id u user name u activ
  • guava 常用用法

    根据 指定大小对 一个大的list拆分成固定size的较小 list Lists partition list n List lt Foo gt foos 61 for List lt Foo gt partition Lists part
  • azkaban plugin在cdh cloudera环境下的配置之 HDFS插件

    安装HDFS插件 1 配置Hadoop环境变量 xff0c 在 etc profile文件末尾增加如下配置 xff1a span class token keyword style color 0077aa export span HADO

随机推荐