浙江省赛2015 _ L _ ZOJ 3880

2023-05-16

水题
题目:ZOJ 3880

There is a popular multiplayer online battle arena game called Demacia of the Ancients. There are lots of professional teams playing this game. A team will be approved as Level K if there are exact K team members whose match making ranking (MMR) is strictly greater than 6000.
You are given a list of teams. Please calculate the level of each team.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (1 <= N <= 10) indicating the number of team members.
The second line contains N integers representing the MMR of each team member. All MMRs are non-negative integers less than or equal to 9999.
Output
For each test case, output the level of the given team.
Sample Input
3
5
7986 6984 6645 6200 6150
5
7401 7377 6900 6000 4300
3
800 600 200
Sample Output
5
3
0

思路:判断有多少个数大于6000即可

代码实现:

#include<bits/stdc++.h>
using namespace std;

int main(int argc, char const *argv[])
{
    int t,n;
    cin>>t;
    while(t--){
        int m,ans = 0;
        cin>>n;
        for(int i=0;i<n;i++){
            cin>>m;
            if(m>6000) ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

小结:题目很水,但是英语阅读能力不够好,以后要锻炼看样例猜题意。手速也比较慢,9分钟才A出。

本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系:hwhale#tublm.com(使用前将#替换为@)

浙江省赛2015 _ L _ ZOJ 3880 的相关文章

随机推荐