POJ - 2531 Network Saboteur

2023-11-16

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer – the maximum traffic between the subnetworks.
Output
Output must contain a single integer – the maximum traffic between the subnetworks.
Sample Input
3
0 50 30
50 0 40
30 40 0
Sample Output
90

这题的题意比较难看懂,将图中的n个点分为两个部分,求出一边所有点到另一边所有点的距离最大值是什么值
只需要枚举所有状况,因为n最大只有20,所以也不用担心超时

首先我们将所有的点标记为0(即所有点放在一个集合里),然后每取出一个点标记为1(即将该点放在另一个集合里),直接暴力深搜,如果取出这个点,我们就遍历原来的集合,更新sum的数据,如果在同一个集合减去他们两个之间的权值,对于不在一个集合里的点,我们加上他们之间的权值。最后的结果为最大值。

#include<stdio.h>
#include<string.h>

int n,k;
int a[32][32],b[32];
void dfs(int s,int sum)
{
     b[s]=1;//利用标记数组划分出两个集合
    for(int i=1;i<=n;i++)
    {
        if(b[i])//如果当前的数在集合中减去当前数到该集合的距离
            sum-=a[s][i];
        else
            sum+=a[s][i];//否则加上
    }
    int max=k;
	if(max<sum)
    	k=sum;
    for(int i=s+1;i<=n;i++)//枚举下一个点再加入集合
    {
        b[i]=1;
        dfs(i,sum);
        b[i]=0;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        k=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        memset(b,0,sizeof(b));
        dfs(1,0);
    printf("%d\n",k);
    }
    return 0;
}
本文内容由网友自发贡献,版权归原作者所有,本站不承担相应法律责任。如您发现有涉嫌抄袭侵权的内容,请联系:hwhale#tublm.com(使用前将#替换为@)

POJ - 2531 Network Saboteur 的相关文章

  • JS原型

    原型的概念 实例对象中 proto 是原型 是一个属性也是一个对象 是给浏览器使用的 是不标准的 这个叫隐式原型 构造函数中的prototype是原型 是一个属性也是一个对象 是给程序员用的 是标准的 proto 原型是浏览器使用的 有些浏
  • JDBC-数据库连接字符串

    SQLSERVER Connection conn DriverManager getConnection jdbc sqlserver localhost 1433 sa Oracle Connection conn DriverMana
  • 什么是rem单位和em单位?它们有什么区别?

    聚沙成塔 每天进步一点点 专栏简介 rem 和 em 单位 rem 单位 Root Em em 单位 区别总结 写在最后 专栏简介 前端入门之旅 探索Web开发的奇妙世界 记得点击上方或者右侧链接订阅本专栏哦 几何带你启航前端之旅 欢迎来到

随机推荐